?

Log in

No account? Create an account

Previous Entry | Next Entry

Gnome Ponderances

</td>
weather: sunny
mood: confused
music: Jose Carreras - Amapola

THE Gnome, not a "deformed dwarf of folklore who lives in the earth and usually guards treasure" gnome.

Anyway, you'd think that because I'm running the Gnome desktop environment on Heretic (my Linux box), that I would bloody-well HAVE the libgnomeui-2.0 library. Apparently not.

"$ find . -name libgnomeui" showed me "/usr/include/libgnomeui/libgnomeui.h" but that's it.

I'm sitting here downloading gnome-libs-1.4.1.2.90-14 and I'll see if that helps. If not, I'm giving up on Drivel (the Gnome LJ Client).

[Update - 2345h]

Huh. I get conflicts when I try to install gnome-libs... well, yeah, I could have guessed that it would. =\ What's also interesting is that I get a dependency error from gnome-libs-devel when I try to do an Upgrade, but I don't have gnome-libs-devel installed. It tells me that it's not installed when I try to remove it.

Oh well, I'll see if I can ask A Smart Person® for help in the morning =P

Not quite ready to completely give up on Drivel yet.


Comments

( 5 comments — Leave a comment )
ntang
Jun. 9th, 2002 05:10 pm (UTC)
If you're still having trouble, lemme know, I might be able to help.

Also, if you're running Gnome, are you running Ximian Gnome? It's a really nice distro of Gnome (the semi-official one) that has a lot of nice extras not included in the default Gnome. http://www.ximian.com/ One of those nice extras is a gui based installer which automatically finds and install dependencies (for things it has in its db anyways... while I doubt it has drivel, it probably DOES have the library you need :) ).
bride
Jun. 9th, 2002 05:41 pm (UTC)
Re:
That's what I ended up doing =) I installed EVERYTHING including the *devel* packages.

I didn't see the libgnomeui package in the list of 166 packages it said it wanted to install though... I'm hoping that's because it lives in something else... =P
ntang
Jun. 9th, 2002 06:09 pm (UTC)
Re:
Actually the problem is probably in the version number. Production Gnome is v1.4; if it said it needed libgnomeui 2.0 it might be using the alpha (beta?) version of the gnome ui libraries (the next planned release after 1.4 is 2.0), which is pretty bad form unless it's also in alpha/beta and is due to be released sometime around Gnome 2.
bride
Jun. 9th, 2002 06:17 pm (UTC)
*cry* Okay... it's still stopping on libgnomeui-2.0. If the client doesn't have a community listed, do I just ask the creator for help?
ntang
Jun. 9th, 2002 06:21 pm (UTC)
Re:
Yeah, or as I mentioned in the earlier comment, just install the 2.0 version of that library. Ximian has a channel where you can install the 2.0 versions of things, if you subscribe to that channel you can install it from there.

If you're confused or whatever, I'm on aim, just ask. :)
( 5 comments — Leave a comment )

Profile

eLouai
bride
The Bride of the First House

Latest Month

March 2015
S M T W T F S
1234567
891011121314
15161718192021
22232425262728
293031