?

Log in

No account? Create an account

Previous Entry | Next Entry

Demonstrating a Semagic Bug

This is Regular, 9pt, Courier New

這是中文字... Hello, what is this?

This is has now become a different font...

[Update]

Display Font Bug is logged here.

Note: Please see this screenshot. The problem is not in the browser, the problem is in the Semagic client window.

[Update]

Status: Resolved
Resolution: By Design

I think this bug is a result of Microsoft's RichEdit 2.0 engine... OMFG, my project at work depends on this piece of schite and we're having a lot of problems with it there as well. *GRRAAAAA* >K{


Comments

( 38 comments — Leave a comment )
incognita
Jan. 7th, 2004 07:42 pm (UTC)
I have a confession to make.



I'm scared to use a different browser because I'm sooooo used to IE... but I'm tired of seeing all the little boxes in your posts. Can you suggest a simple, but better one? One that is super super easy to use?
ntang
Jan. 7th, 2004 07:54 pm (UTC)
http://www.mozilla.org/products/firebird/

Firebird is great, it's very simple, completely free, and has all sorts of nice default behaviors like blocking pop-ups.
bride
Jan. 7th, 2004 08:12 pm (UTC)
*beam* Mozilla =D

A browser is a browser is a browser =) You can download different skins with Mozilla... gah, just go try it out and I'll show you how to do all kinds of nifty things =)
(no subject) - ntang - Jan. 7th, 2004 08:16 pm (UTC) - Expand
(no subject) - bride - Jan. 7th, 2004 08:28 pm (UTC) - Expand
(no subject) - sertrel - Jan. 7th, 2004 08:34 pm (UTC) - Expand
(no subject) - ntang - Jan. 7th, 2004 08:38 pm (UTC) - Expand
(no subject) - bride - Jan. 7th, 2004 09:04 pm (UTC) - Expand
(no subject) - ntang - Jan. 7th, 2004 09:23 pm (UTC) - Expand
(no subject) - bride - Jan. 7th, 2004 09:26 pm (UTC) - Expand
(no subject) - astral - Jan. 8th, 2004 05:21 am (UTC) - Expand
(no subject) - bride - Jan. 8th, 2004 09:04 am (UTC) - Expand
(no subject) - astral - Jan. 8th, 2004 09:26 am (UTC) - Expand
(no subject) - bride - Jan. 8th, 2004 10:05 am (UTC) - Expand
(no subject) - astral - Jan. 8th, 2004 04:48 pm (UTC) - Expand
bride
Jan. 7th, 2004 10:28 pm (UTC)
Gen,

I have both, but I'm actually using Firebird 0.7 (stand-alone browser by the same people who make Mozilla). It uses up more memory than Mozilla, but I may be in the minority.

Either of them are a huge improvement over IE and they're not so different that you have to re-learn how to do anything =) And the internet will be _so_quiet_ for you without the pop-ups =)

You might need to set up the Chinese support if you're interested in seeing the Chinese properly =) If you're on Win2K, I have instructions here.

I don't have instructions typed up for WinXP, I'll have to do that when I'm at work. But you don't need the installation CD to do it in WinXP. =)
(no subject) - incognita - Jan. 8th, 2004 06:23 am (UTC) - Expand
(no subject) - bride - Jan. 8th, 2004 10:11 am (UTC) - Expand
sertrel
Jan. 7th, 2004 07:46 pm (UTC)
Is that supposed to be Courier New in your post? It looks like default font for my pages (Verdana) to me from here...
bride
Jan. 7th, 2004 08:25 pm (UTC)
Display Font Bug is logged here. =)
(no subject) - sertrel - Jan. 7th, 2004 08:41 pm (UTC) - Expand
(no subject) - bride - Jan. 7th, 2004 08:59 pm (UTC) - Expand
(no subject) - sertrel - Jan. 7th, 2004 09:26 pm (UTC) - Expand
(no subject) - bride - Jan. 7th, 2004 09:28 pm (UTC) - Expand
(no subject) - sertrel - Jan. 7th, 2004 09:45 pm (UTC) - Expand
(no subject) - bride - Jan. 7th, 2004 09:49 pm (UTC) - Expand
chenpion
Jan. 7th, 2004 07:52 pm (UTC)
... well, I get Chinese...
... is that what's supposed to happen?
bride
Jan. 7th, 2004 08:26 pm (UTC)
Re: ... well, I get Chinese...
Display Font Bug is logged here. =)
chenpion
Jan. 7th, 2004 08:35 pm (UTC)
Interesting...
You got the new semagic client already? I was wondering when it'd come out...

To me, the fonts before and after Chinese are the same. Just so you know. Using Win2K... on IE6.
Re: Interesting... - bride - Jan. 7th, 2004 08:52 pm (UTC) - Expand
Oh, wait... - chenpion - Jan. 7th, 2004 08:57 pm (UTC) - Expand
Re: Oh, wait... - bride - Jan. 7th, 2004 09:11 pm (UTC) - Expand
ntang
Jan. 7th, 2004 08:03 pm (UTC)
It's not putting any font info into the post body at all.

<div style='margin-left: 30px'><font face='Arial,Helvetica' size='+1'><i><b>Demonstrating a Semagic Bug</b></i></font><br />
<p>This is Regular, 9pt, Courier New

<p>這是中文字... Hello, what is this?

<p>This is has now become a different font...</div>

Obviously, as Semagic is a russian product, this is a communist plot.
bride
Jan. 7th, 2004 08:26 pm (UTC)
Display Font Bug is logged here. =D
ntang
Jan. 7th, 2004 09:32 pm (UTC)
Actually, WordPad in WinXP does the same thing when I copy/paste the source into it. I think it's not actually a Semagic bug, I think it's a Windows bug. Try it in Wordpad or some other apps. They probably use the same (buggy) Windows rendering widget. It's because the Chinese text requires a different font and changes the encoding to Chinese GB2312, which is never reset back to Western... there may be some way to fix it, but my guess is that it's just in the way that Windows handles foreign encodings.

(MS Word seems to handle it fine, but it has a different text rendering engine than the one built into Windows.)
bride
Jan. 7th, 2004 09:37 pm (UTC)
Aw crap... I'll bet it's the RichEdit engine. Graaaa... ={
razorw
Jan. 7th, 2004 10:09 pm (UTC)
LOL. How fun life can be.
bride
Jan. 7th, 2004 10:12 pm (UTC)
Heh, yeah... *shakes head* =\ =)
( 38 comments — Leave a comment )

Profile

eLouai
bride
The Bride of the First House

Latest Month

March 2015
S M T W T F S
1234567
891011121314
15161718192021
22232425262728
293031